HiveMQ

Unable to connect using Domoticz and Tasmota Device and Hivemq.cloud

Hello,

I was trying to use Domoticz app to control the lights attached to my tasmota device. I followed all the directions on how to configure at Domoticz - Tasmota
Looks like I don’t need to do anything special on my tasmota device and it should work. Needless to say I can’t control my device from the Domoticz on my PC.

I did enter “36” in Idx1 setting in tasmota which is Idx number assigned to the virtual switch in Domoticz. I also entered Hivemq.cloud settings and kept TLS version settings at default tlsv1 in Domoticz.

at this point I think either the Domoticz doesn’t work with hivemq.cloud and needs a local broker or I am missing some configuration settings.

So my question: Is it possible to control my tasmota device with domoticz using hivemq.cloud and without using a local in house Mqtt broker?

Could it be a TLS problem? Domoticz gives option to use tlsv1. or tlsv1.1 or tlsv1.2. which version does hivemq.cloud use?

Regards,

Navi

Hi @NsinghP,

if you are using HiveMQ cloud “basic” then the configured TLS is v1.2. So TLSv1 won’t work.

Greetings,
Michael

Thanks Michael, Though I am selecting TLS v1.2 in Domoticz app it still does not work I get the following error:

2021-06-17 11:40:11.420 Status: Hazel Test Module1: MQTT: Connecting to 9d3…787.s1.eu.hivemq.cloud:8883
2021-06-17 11:40:12.908 Error: Hazel Test Module1: MQTT: disconnected, restarting (rc=7)

I think there is some incompatibility in TSL v.1.2 being used by Domoticz and the version being used by HiveMQ.cloud basic. I will try posting the error in Domoticz support page. Please share if you have any idea on how to resolve this on your end.

Regards,

Navi