Node Red 'connecting' to HIVE MQ

I am using Node Red install on a Raspberry Pi
When using the HIVE Public Broker ( port 1883) , we are getting connected and working
When using the HIVE Cloud Broker( port 8883), the MQTT node just shows the yellow “connecting” message and thus not working.

I have checked our Network Router and opened the NAT Gaming Port 8883 for the Raspberry pi , but that still does not solve the problem.
Any ideas?

Hi @octava,

the public broker does not have any TLS listener whereas the Cloud broker has only TLS listeners.

For you this mean you need to check the “Enable secure (SSL/TLS) connection” box (you can see it in your image already).

As for setting up TLS with Node Red I redirect you to this thread: Node-Red TLS connection

Greetings,
Michael from the HiveMQ team

1 Like

Hi Michael,
Thank you for the response.
I did just now set the “Enable secure (SSL/TLS) connection”
1.entered the user and Passcode that matches the cluster.
2. Also followed instruction to include a “server/CA certificate” from the FAQ
Downloaded from the FAQ…

However it is the same issue, the MQTT node just sits there at “CONNECTING”

Hi @octava ,

Try setting the Client ID and test again:

I hope it helps.

Kind regards,
Dasha from HiveMQ team

Hi Michael,
Entered a client ID ‘myPi1’.
But still the MQTT node still just hangs at “connecting” instead of ‘connected’ ( green)

If anyone has a working NodeRed ‘flow’, please kindly share. As I can see lot of NodeRed community members would want to work IoT with the HIVE MQ

Finally got it working.
Did a clean install of:

  1. Raspberry OS
  2. Re-installed Node

    Red and NODE JS using instructions here.
    Running on Raspberry Pi : Node-RED

So I believe the problem is with node.js version and Node Red versions

1 Like