Cannot remove DISABLED file from Kafka extension

Hi, first time I was able to remove DISABLED file present in Kafka extension and it worked fine but after 5 hours when i restarted the hivemqbroker, Kafka connection to event hubs was broken. The disabled file was present again in kafka extension folder. When i tried to remove it, the command is executed without any errors but DISABLED file is not deleted and hence kafka connection to event hubs is not showing up.

Hi @heman,

the Kafka extension is an enterprise extension. This means as long as you don’t have an license for the Kafka extension in place you only get a trial period that lasts 5 hours.

If you restart the broker you should get again the 5h trial period. So I’m confused as you said you restarted the broker and it didn’t work can you explain how you did restart the broker?

Also it would be helpful if you could provide the hivemq.log so we can see what HiveMQ logged when you removed the DISABLED file.

Michael from the HiveMQ team

Thanks for your reply. I used “./bin/” script in installed directory to restart. I realized that it may not be the correct method. Can you please suggest correct method to restart the hive mq broker. I have installed it on the Azure VM using ARM template. Getting data from log file seems to be bit complicated.

Using “./bin/” is correct, assuming you stopped the HiveMQ broker beforehand.

You get the logs from the “log” folder (the hivemq.log file), it’s in the same directory as the “bin” folder.
Bildschirmfoto 2022-10-25 um 22.23.33


Thanks Michael. I managed to restart the cluster. Just needed to kill the background hivemq process and it started the clusted again automatic. Now, I am able to remove DISABLED file, however on dashboard it displays that Kafka is missing configuration file while configuration file is present and it worked last time. This seems to be bit strange. Do you know the cause of the issue?