We made a simple tutorial to help you send message using our MQTT Web Client

The HiveMQ Cloud web client is a ready-to-use client within the Cloud user interface that helps you connect to your devices easily with the Cloud Broker.

We wrote a blog to show how to use web client GUI to connect to the HiveMQ Cloud Broker and send messages.

Thanks for that. But I failed in “Connecting to MQTT Broker / Cluster” step. Web-client always disconnected. How is that?

Hello, @walton

Thank you for the outreach!

I wanted to confirm a few additional details to provide some additional assistance.

  • Which HiveMQ broker are you using?
  • Is the web client able to connect, initially, and then the disconnect occurs, or does this happen after a certain event, such as a publish or subscribe?
  • Are any other clients able to successfully connect, publish, and subscribe on the broker?
  • If possible, please share any other configuration details - this may help us further diagnose.

Many thanks for the interest in HiveMQ, and we look forward to hearing back from you soon!

Aaron from HiveMQ Team

wow, thanks for your help. I am new to all these MQTT or HiveMQ things, I just follow the steps in this article Send MQTT Messages in 10 Minutes Using HiveMQ Cloud Web Client.
and stuck in in connect part.

you see. Web-Client disconnected.

in the article, it should work like this

Hello @walton,

Thank you for the follow-up! I did just attempt to utilize a web client connection on my personal cloud environment, and was unable to replicate what you are currently experiencing.

I’d like to have you attempt to use the ‘connect with generated credentials’ option again, as this will automatically repopulate the connection field with the generated credentials. This may require you to disconnect the current client, if the disconnect option is present, and refresh the page before generating the new client.

Additionally, if you could test with custom-made credentials, as well, this may help us diagnose further. This can be done by navigating to your cluster, selecting ‘access management’ from the top menu, and using the credential creation tool at the top of the page.

If there are a large number of generated credentials saved in the list below, as well, it may be best to clear out unused entries.

Aaron from HiveMQ Team

I used the ‘connect with generated credentials’ option again. Web-Client still show disconnected.
Here is the Credentials

It’s really weird.
I log in with my google account.

Hello @walton ,

Could I have you try creating new credentials in this credential page, and then logging in with the web client using those credentials? This will help us identify if the issue looks to be occurring with the credential creation process, or with the client connection process.

Aaron from HiveMQ Team

I created a new credential, which is “credential-1”,and loging using this credential. Still disconnected. I believe the issue occur in client connection process.

Here is the credential I just created.

I add more screenshot for you to check.

Hello @walton ,

Thank you for the follow-up! That behavior does look to be unexpected, based on the configuration details that I can see.

Would it be possible to test a connection using the HiveMQ CLI Client? More information for this tool, including installation and usage details, are available here. This is a great, non-websocket tool for testing connectivity to a broker, and will help us identify if the issue is with the websocket connector (port 8884), or if the issue persists on the standard MQTT connect port 8883.

Aaron from HiveMQ Team

After I installed MQTT. I tied connect like this, and got an error message.

Maybe you can try connect from your side. I will give you the information you need.
Cluster URL: 472339bf0ec7420b8edde1e3c394c04e.s2.eu.hivemq.cloud
Port: 8883
Websocket Port: 8884


Interesting. I can connect well when I came home. It seems something wrong in the campus. Maybe the firewall of our campus…Thanks for your help. I will try to connect again using wifi in the campus on Monday.