File RBAC Extension connection not authorized error

Hi , I am new with the HiveMQ CE
I’m successfully connected to the broker without any security
but when I have tried with the File RBAC Extension, I have the following error “Connection refused: Not authorised”

I think that the setup of the broker is OK
Also I have generated the password using the java tool
after that I have modified the credentials file of the extension
I am running the broker on a Windows OS

So I don’t know what is the issue ?
any help please !


Here are some common troubleshooting steps for the HiveMQ File RBAC extension:

  1. Check that the extension is enabled in your HiveMQ broker installation.
  2. Check the configuration file: Make sure that the configuration file, “rbac-config.xml”, is located in the correct directory and that it is properly formatted. Verify that the roles, permissions, and users are defined correctly.
  3. Check the log files: HiveMQ generates log files that can provide information about any errors that may have occurred. Check the log files for any error messages related to the RBAC extension.
  4. Verify the client’s credentials: Make sure that the client is providing the correct username and password when connecting to the broker. The client’s username should match the username defined in the configuration file.
  5. Check the client’s permissions: Verify that the client has the correct permissions for the operations it is trying to perform. Make sure that the role associated with the client’s username has the necessary permissions.
  6. Check the client’s connection: Verify that the client is connecting to the correct broker and that the broker is configured to use the RBAC extension. Make sure that the client is using the correct port and protocol (e.g., MQTT or MQTT over WebSockets).
  7. Check the official documentation: HiveMQ’s documentation is a great resource for troubleshooting problems and finding solutions.

I hope this helps,
Kind regards,
Dasha from HiveMQ Support

Hello Daria
thank you for your reply and help
the cause of my problem that I was inserting the generated hashed password to the client and not the original password

Hi @BOU ,

This is great you found the issue and fixed it, well done!

Should you need further help, let us know.

Kind regards,
Dasha from HiveMQ Team

1 Like