Can't connect to my cluster

I am trying to use the HiveMQ Cloud service for the first time. But i can’t seem to connect to my cluster.
I tried 3 methods already (Webclient, MQTT CLI & MQTT.fx) but they all have the same issue.
Connection faillure due to ‘connection time out’.

Does somebody know how to fix this?

Hello, @WoutVDW !

First off, welcome to the HiveMQ Community! We’re always happy to see new faces interested in MQTT.

There are a few items that are worth checking out of the gate :

  • The HiveMQ Cloud broker requires an SSL connection, so the connecting client must support an SSL connection to successfully complete connection.
  • When using WebSocket connections, such as with a WebClient, the HiveMQ Cloud Broker utilizes port 8884 by default, rather than port 8883.
  • When using MQTT CLI to initiate a connection, the additional option -s enables a secure session, allowing for TLS.

With that in mind, if you could provide the connection configurations that you are attempting, we would be more than happy to review further - please be sure to obfuscate any connection information that may be private, such as the start of the broker URL, usernames, and passwords.

Aaron from the HiveMQ Team

Thanks for the reply

I don’t know if i have an SSL connection, how can i check? (don’t have much experience)
With Webclient option, I don’t see a option to select my port.
Client Connection Settings
When i try to connect here, it just fails.
The command that i used for MQTT CLI already had a -s in it.

Hopefully i gave you enough info.
Thank you in advance!

picture of the command prompt

Hello @WoutVDW ,

Thank you for the follow-up!

The connection information offered in both the command prompt and web client appear accurate, and should allow successfully connectivity to the Broker host - with that in mind, the failure that we are seeing would be consistent with the provided credentials being rejected by the broker.

For a test, try utilizing the ‘Connect with Generated Credentials’ option in the WebClient - this will generate new credentials and automatically connect the client with these new credentials, and should allow us to test a connection without any potential credential errors.

Let us know if you are able to give this a shot, or if you encounter any further bumps along the way!

Aaron from the HiveMQ Team

Hey @AaronTLFranz

I tried to use the ‘Connect with Generated Credentials’, but stil have the same issue.
I also tried to put those credentials in MQTT CLI but also there it doens’t work.

Kind regards

In the meantime i tried pinging to see if i can actually reach the brokers.
I tried the standard and own broker. Both ping requests timed out.
Could it be that internet connection in my company pervets me from connecting (i’m doing my student job). So i don’t know the setup here.

Hello @WoutVDW

An easy way to test if any company security policy on your Windows machine is blocking you.

Open Windows Power Shell terminal and type both commands below.

tnc -port 1883



Kind regards,
Diego from HiveMQ Team

Hello @Diego and @AaronTLFranz

I tried what you said in Power Shell and this is the result.
What do you make of it?

Hello @WoutVDW

You are being blocked! In fact, some security policy of your company or even an anti-virus installed locally on your computer may be blocking access to these ports 1883 or 8883.

Kind regards,
Diego from HiveMQ Team

1 Like