Where to get started - basic download and install Ubuntu

Hey all, running mosquito and looking for something more robust and stable, so trying to get this CE up and running and there is a few issues out of the box I can’t seem to fine.

The first is from the 4.7 document directly from the site - General Installation Information :: HiveMQ Documentation

It says to goto the download page and download, yet that is a form and the enterprise version.

Next, I tried going to the GitHub version which appears to be the community edition;

I was able to download the build version, and from step 2;

./gradlew clean packaging

I am getting the following error:

FAILURE: Build failed with an exception.

  • What went wrong:
    Task ‘packaging’ not found in root project ‘hivemq-community-edition’.

  • Try:
    Run gradlew tasks to get a list of available tasks. Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

So, is there an easy way to download the .zip, unpack and move on?

If not, how do I get past this issue?

I am currently testing on Ubuntu 20.04LTS, but can drop back one to 18.04. I am testing on AWS and even see they have an AWS AMI image, but that is not the community edition!

Thanks for all read/replies

Hi @lance.raymond,

You can find the zip’s of the CE releases here:

And it seems the README is not up to date, “packaging” is now “hivemqZip”.

P.S.: There is also a docker image for CE should you prefer this: Docker Hub

Michael from the HiveMQ team

1 Like

Ah that worked perfect.

Have things up and running, next step is to look at best practices for open file limits, connection limits as we were hitting connection halting after 2,000 device connections yet CPU and such were all fine.

Regardless, I am going to do some more reading on best practices and tuning!

Thanks for the head start!

This could be of interest for you:

Sorry. never got to get that reply in to say thanks, worked perfect, now to better questions :slight_smile:


Hi @lance.raymond … I am struggling to get the daemon up for hivemq server up on my Ubuntu 20 machine. However I can start it with the shell command run.bat but because the daemon is not working the broker stops as soon as the shell command is killed.
Did you install it on Ubuntu? How did you start the daeman? Would appreciate any help.

Hey @sanjmeh ,

Please check if you have systemd in your ubuntu with:
ps --no-headers -o comm 1.
Is output systemd or init?

Dasha from HiveMQ team

Apologies for the delay. I managed to resolve this and the hivemq is up. It took lot of struggle though.