HiveMQ

Warning: No payload was found for the retained message on topic

We are using HiveMQ to send message from a few publishers (something like 10), to a few applications. For each topic, the consummer need the last message so all our published messaged are retained.

When we are starting the publishers, we first need to clean the topics so to be sure that the information in the broker is uptodate comparing to the one in the publisher. To do that, we send a payload of 0 bytes in each topic (not that much, around 6000 topics).

In hive Mq, I got these funny warning line :slight_smile:
No payload was found for the retained message on topic XXXX after a few days running. The message is a bit weird for me as normally either there is a payload, either, the 0 byte payload means the broker needs to delete the retained topic.

I had a look in HiveMQCE code but could really find a concrete explanation on these logs.

Hi @jonathan.robert,

Thank you for your patience.
Can you please let me know what exact version CE you are using?
It would also help to see the exact log statement.

Kind regards,
Florian form The HiveMQ Team.

The complete log is “No payload was found for the retained message on topic PARCIVAL/SR/XXXXXXX”
Hive v2020.2

very basic configuration file:



1883
0.0.0.0


I had a look in the source code but could really clearly see why I can arrive in that log…

Oups, the config file in a more readable format :slight_smile:

<listeners>
    <tcp-listener>
        <port>1883</port>
        <bind-address>0.0.0.0</bind-address>
    </tcp-listener>
</listeners>