SQL realm connection

I’m facing DB connection problem during enterprise-security-extension start-up as it fails due to incorrect passwords.
All passwords are working when I establish a connection using them manually (via psql).
As passwords might contain special characters I do XML encoding of them every time I fill field (without that I just see that the configuration file is incorrect in logs), see - https://docs.oracle.com/cd/A97335_02/apps.102/bc4j/developing_bc_projects/obcCustomXml.htm

for example,
ee]Yff-rwqn]2dm<cdf ( ee]Yff-rwqn]2dm&lt;cdf ) - works
<-ghdmn+gtgtW:1T ( &lt;-ghdmn+gtgtW:1T ) - doesnt work

As for me it looks like a connection can’t be established when the password contains ‘:’ , ‘@’ or ‘&’ characters

I tried with percent encoding - the same result, it didnt help.

Does ese extension have some restrictions for password characters?

Hello @tar.ant

Welcome to HiveMQ Community! So you don’t need to encode the password characters in the ESE XML config file, just put the password string in a CDATA section and it will work fine, sample below.


Best regards,
Diego from HiveMQ Team