MQTT Message Log NoClassDefFoundError

I made a really basic broker with the HiveMQ Community Edition and a basic Client with the HiveMQ Client. This worked and the client connected after the broker was running. Then I wanted to somehow see messages from the broker, like subscribes and new connections. I added the MQTT Message Log extension from the HiveMQ marketplace like instructed. The broker started and when I tried to connect with the client the client got disconnected instantly, with the following error message on the client side:

Exception in thread "main" com.hivemq.client.mqtt.exceptions.ConnectionClosedException: Server closed connection without DISCONNECT. at com.hivemq.client.internal.mqtt.MqttBlockingClient.connect( at com.hivemq.client.internal.mqtt.mqtt3.Mqtt3BlockingClientView.connect( at com.hivemq.client.internal.mqtt.mqtt3.Mqtt3BlockingClientView.connect( at Main.main(

The broker gave the following error message:

2021-03-31 12:20:58,190 ERROR - An unexpected error occurred for client with IP java.lang.NoClassDefFoundError: com/hivemq/extension/sdk/api/client/parameter/ClientTlsInformation at com.hivemq.extensions.handler.ConnectInboundInterceptorHandler.handleInboundConnect( at com.hivemq.mqtt.handler.InterceptorHandler.channelRead( at at at at com.hivemq.mqtt.handler.connect.MessageBarrier.channelRead( at at at at com.hivemq.mqtt.handler.connect.NoConnectIdleHandler.channelRead( at at at at io.netty.handler.timeout.IdleStateHandler.channelRead( at at at at io.netty.handler.codec.ByteToMessageDecoder.fireChannelRead( at io.netty.handler.codec.ByteToMessageDecoder.channelRead( at at at at io.netty.handler.codec.ByteToMessageDecoder.handlerRemoved( at io.netty.handler.codec.ByteToMessageDecoder.decodeRemovalReentryProtection( at io.netty.handler.codec.ByteToMessageDecoder.callDecode( at io.netty.handler.codec.ByteToMessageDecoder.channelRead( at at at at$HeadContext.channelRead( at at at at$ at at at at at io.netty.util.concurrent.SingleThreadEventExecutor$ at io.netty.util.internal.ThreadExecutorMap$ at java.base/ Caused by: java.lang.ClassNotFoundException: com.hivemq.extension.sdk.api.client.parameter.ClientTlsInformation at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass( at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass( at java.base/java.lang.ClassLoader.loadClass( ... 41 more

In short I dont know what the problem is since these error messages dont make a lot of sense to me. If anyone could explain my mistake or point me towards a solution, that would be great. Thanks for reading!