I am facing an issue while trying to install HiveMQ edge on windows PC

When i run <hiveMQ-dir>bin/run.bat command in CMD, i receive error “| was unexpected at this time.” I donot know how to tackle this.

Hello @1shubham ,

Thank you for the outreach - we would be happy to assist!

In order for us to dive in deeper, we’d like to collect some additional details regarding your installation :

  • Which version of Windows is this machine currently utilizing?
  • Is this being run as an administrator, or as a standard local user on this system?
  • Please provide the full export of this error messaging, if possible, as text rather than an image.
  • As it looks like the provided directory here indicates this being deployed from \hivemq-edge\build\distribution\hivemq-edge-2023.9\bin, could I have you confirm if the binary image was obtained from our github, here, or if the repository was downloaded directly and then built?

Let us know your thoughts!

Aaron from the HiveMQ Team

HI Aaron, thanks for the reply.

  1. I am using “Windows 11 home” version “23H2” with OS build “22631.2861”.

  2. Yes, its been executed as administrator role.

  3. I don’t understand what is meant by “full export of error messaging”. Although when i ran " ./<HiveMQ-dir>/bin/run.bat" as told in this article at HiveMQ website, i got the error “I was unexpected at this time”

  4. I have tried both ways, but both resulted in same error.


@AaronTLFranz , Hi Aaron waiting for your reply.

Hello @1shubham

I encountered the same issue on my Windows machine. It appears that the underlying issue could stem from the unescaped characters within the HiveMQ Edge ASCII Art. By removing the ASCII Art section from the script, I was able to achieve successful execution on my system.

Another workaround that I found was adding a double quotation on HiveMQ Edge ASCII Art, this also resolved the issue.

Kind regards,
Diego from HiveMQ Team

Hi @Diego , Thanks for the reply.

I have tried both workarounds as you told, and they worked.

For Future viewers,

  1. Open ‘run.bat’ file in notepad

  2. Either remove the ASCII art as shown

  3. Or surround the ASCII art with double quotes instead of single quote

Save the text file and run the ‘run.bat’ file with administrator privilege

Hi @1shubham

You’re welcome! I wanted to inform you that the HiveMQ Edge developers are already aware of this issue and it will be addressed in an upcoming release of HiveMQ Edge.

Kind regards,
Diego from HiveMQ Team