HiveMQ Edge - Creating More Than One Topic Causes Error In Protocal Adapter

I am using the MODBUS Protocal Adapter. I have 5 modbus addresses mapped to one topic. If I try to create a second topic to map a second series of addresses too, the Protocal Adapter will go into error.

To verify there wasn’t a problem with the groups of modbus ponts, I tried to create a single topic with both series of addresses mapped to it. The Protocal Adapter stayed connected. I then created a single topic with only the first group of modbus addresses mapped. The Protocal Adapter stayed connected. I then created a single group with only the second group of modbus addresses mapped. Again the Protocal Adapter stayed connected.

I’m not sure if my problem is procedural or if this is a bug.

Hi,

Great that you working with the ModBus adapter. I do not fully understand the problem, yet to further help you. May you please provide the error message.

Do you config these adapters in the config.xml or in the UI?

Best wishes,
Stefan

Hello Stefan,

I am using the GUI for configuration.

I want to map modbus addresses to different topics (segregated by their function). I can map addresses to a single topic fine. However, when I try to create a second topic and map addresses to it, the protocal adapter shows “error” for a connection status on the GUI.

To clarify, I am not trying to map the same modbus addresses to multiple topics.

I tried to re-produce your problem but didn’t run into an error.

May you please send a screenshot or parts of the config.xml.

Note: Please be aware not to share any secrets.

Best wishes,
Stefan

When I try to create more than one MQTT topic for modbus addresses coming from a modbus server through a HiveMQ Edge modbus protocal adapter, the protocal adapter goes into “error” on the GUI.

I will recreate the problem localy and attach a santized config file.