Authorization error/ Using TLSv1.3

I have built project based web page

and getting the following error message
Connecting to on port 8883 …
Connect failed: ConnectResult[Code: NotAuthorized]

Is this example complete or guide me to resource to complete the project and use.
I want to use TLS v1.3 with self signed certificate for time being.

Hello @rasheeda

Welcome to HiveMQ Community! Could you please try creating a new credential in HiveMQ Cloud portal and share the results?

Kind regards,
Diego from HiveMQ Team

Thanks for the reply.

I did create credential and able to login using web client of hivemq and publish message.
How can i see the published message?
I tried: To see published message, created another user for the same cluster. But when i login on web client with another user, first user logs out.
Using a free cluster for testing.
Also, tried to connect with mqttexplorer program, getting Not authorized message.
Appreciate the help in this regard.

Hello @rasheeda,

Thank you for updating us on your successful connection and message publication using the Web client. It’s important to note that the Web client supports only one connection at a time. To view the published messages simultaneously, you can connect using another user with different tools such as MQTT CLI or MQTT Explorer. Detailed steps on using MQTT CLI can be found in the “Getting Started” section of the HiveMQ WebUI.

Regarding the error you encountered with MQTT Explorer, it appears that the “validate certificate” option is not enabled which is also required. Kindly enable this option and attempt to reconnect to the HiveMQ broker.

We hope this helps, Feel free to let us know if you face any issues.

Sheetal from HiveMQ Team

Thanks for your response. Today MQTTExplorer started working, can publish the message, there is no option to subscribe in mqttexplore. Is that the way it is.

I have two more question, please

  1. Tried with mqtt.fx works for both publish and subscribe works fine with TLSv1.2, when i change TLSv1.3 in .fx setting, get error protocol version as attached
  2. this newbe question, in case of TLS protocol no need to provide any certificate in client? or in what case need to provide the certificates (why so many options given)

Thanks in advance

Hi @rasheeda

Thank you for reaching out with your questions. We’re happy to assist you, although it’s important to note that MQTT Explorer is not developed by HiveMQ. Nevertheless, we’ll do our best to help you.

Regarding your questions:

  1. MQTT Explorer and Subscriptions: MQTT Explorer does have the capability to subscribe to topics. There is a configuration page where you can specify subscription topics. We’ll attach a screenshot to illustrate this.

  2. TLSv1.3 and MQTT.fx: The error you encountered when switching to TLSv1.3 in MQTT.fx is likely due to compatibility issues. Currently, the HiveMQ Cloud Serverless broker supports TLSv1.2, not TLSv1.3. If you encounter issues, it’s recommended to use TLSv1.2 for now.

  3. Why so many options given: MQTT.fx and MQTT Explorer clients are designed to work with various MQTT brokers, not only with a HiveMQ Cloud broker. This is why there are so many various connection options. Sometimes, the client or its underlying MQTT library already contains the server’s certificates and trusts the server’s CA. In those cases, the client is allowing you not to specify the certificate.

Please feel free to reach out if you have further questions or if you need additional assistance.

Dasha from HiveMQ Team

Thank you, appreciate the help.