HiveMQ

#AMAMQTT | If a broker fully supports MQTT 3.1.1 specification, does it mean that we can use it for SPARKPLUG MQTT or still it shall have extra specifications?

This question was asked during the webinar titled “Ask Me Anything About MQTT: Take 2” held on October 26. 2021 by Babak.

Answer: Yes. You can use an MQTT broker that supports MQTT 3.1.1. Kindly note that the broker must support:

  • QoS 0 and 1

  • Retained Messages

  • Last Will and Testament

  • A flexible security system

For more details, refer to our MQTT Sparkplug Essentials series.

You can also use our open-source Sparkplug extension.