MQTT.fx Hivemq version cannot be opened


When i tried to open the app, it keeps showing this error. I have already checked and updated my Java and followed instruction from here:

Now my java version is below,

“java version “22.0.1” 2024-04-16
Java™ SE Runtime Environment (build 22.0.1+8-16)
Java HotSpot™ 64-Bit Server VM (build 22.0.1+8-16, mixed mode, sharing)”,

Which should be able to run class file versions up to the 66.00 (while the app only need 65.00). But the error keep saying that my java runtime could only run up to version 60.00. What should i do to fix this?

Hi @asyarif

it’s wonderful to have someone like you who’s enthusiastic about MQTT and the HiveMQ broker. Welcome to the HiveMQ Community! We’re excited to see new users like you.

Thank you for reaching out. Could you please try using a lower version of Java, such as JDK 11, and let us know if the issue persists? You can download it from the following link: JDK 11 Download.

We appreciate your cooperation and look forward to your update.

Best regards,
Dasha from the HiveMQ Team

Hi @Daria_H ,
Thank you very much for the suggestion, but it seems the problem is not solved yet. It keeps showing the same error.

Hello @asyarif ,

Thank you for the follow-up!

It is worth noting that multiple Java versions are able to be installed concurrently, and the Java version utilized by one application may be different than that identified with the Java command.

Could I please have you confirm the operating system that you are currently utilizing, as well as the updated Java version? This will allow us to better provide instructions for confirming the specific Java version.

For example, some Linux distributions may not automatically update the JAVA_HOME variable, depending on installation method used, to this new Java version, which may require a manual update for the utilized shell.

Let us know your thoughts!

Aaron from the HiveMQ Team