# Change the localhost ip to my server ip

**URL:** <https://community.hivemq.com/t/change-the-localhost-ip-to-my-server-ip/1654>\
**Category:** HiveMQ Community Edition\
**Created:** [December 3, 2022, 5:35pm UTC](https://community.hivemq.com/t/change-the-localhost-ip-to-my-server-ip/1654 "2022-12-03T17:35:53Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![hejazi090](https://yyz1.discourse-cdn.com/flex035/user_avatar/community.hivemq.com/hejazi090/32/500_2.png) [@hejazi090](https://community.hivemq.com/u/hejazi090)\
**Post date:** [December 3, 2022, 5:35pm UTC](https://community.hivemq.com/t/change-the-localhost-ip-to-my-server-ip/1654/1 "2022-12-03T17:35:54Z")

</div>

Hi dears,  
Kindly I would like to know how can I change the local host IP if I run the docker image on my server so I can open the control center from my windows browser.

I did the below changes

 ![img1](https://canada1.discourse-cdn.com/flex035/uploads/hivemq1/original/1X/f526d2a3967747e5940234f31b7fb3486c34bbb9.png)

and then I got the below error

```auto
2022-12-03 17:20:59,304 INFO - Extension "Allow All Extension" version 1.0.0 started successfully.
2022-12-03 17:21:01,485 INFO - X0zNS: no members discovered after 2001 ms: creating cluster as first member
2022-12-03 17:21:01,536 INFO - Starting HiveMQ Control Center on address *******.cloud and port 8088
2022-12-03 17:21:01,843 ERROR - Not able to start HiveMQ Control Center: Failed to bind to *******.cloud/****** :8088
2022-12-03 17:21:01,862 INFO - Starting TCP listener on address *******.cloud and port 1885
2022-12-03 17:21:01,893 INFO - Starting Websocket listener on address *******.cloud and port 8000
2022-12-03 17:21:01,905 ERROR - Could not start TCP Listener on port 1885 and address *******.cloud. Is it already in use?
2022-12-03 17:21:01,905 ERROR - Could not start Websocket Listener on port 8000 and address *******.cloud. Is it already in use?
2022-12-03 17:21:01,906 ERROR - Could not bind any listener. Stopping HiveMQ.
2022-12-03 17:21:01,914 INFO - Shutting down HiveMQ. Please wait, this could take a while...
2022-12-03 17:21:03,954 INFO - Shutting down extension system
2022-12-03 17:21:03,968 INFO - Stopping extension with id hivemq-allow-all-extension
2022-12-03 17:21:03,970 INFO - Extension "Allow All Extension" version 1.0.0 stopped successfully.

```

---

<div class="post-metadata">

**Author:** ![hejazi090](https://yyz1.discourse-cdn.com/flex035/user_avatar/community.hivemq.com/hejazi090/32/500_2.png) [@hejazi090](https://community.hivemq.com/u/hejazi090)\
**Post date:** [December 3, 2022, 5:37pm UTC](https://community.hivemq.com/t/change-the-localhost-ip-to-my-server-ip/1654/2 "2022-12-03T17:37:34Z")

</div>

it was working when the hostname was 0.0.0.0

---

<div class="post-metadata">

**Author:** ![Seth.HiveMQ](https://avatars.discourse-cdn.com/v4/letter/s/85e7bf/32.png) [@Seth.HiveMQ](https://community.hivemq.com/u/Seth.HiveMQ)\
**Post date:** [December 6, 2022, 6:02pm UTC](https://community.hivemq.com/t/change-the-localhost-ip-to-my-server-ip/1654/3 "2022-12-06T18:02:25Z")

</div>

Hi Amer Abdulrahman Hijazi,

Were you able to get this working for your installation in the end? (just double-checking given your last reply to your topic)

I don’t know all the details of the setup you are using, but you may find the below documentation useful:

HiveMQ Docker:  
[https://www.hivemq.com/docs/hivemq/4.9/user-guide/getting-started.html#docker](https://www.hivemq.com/docs/hivemq/4.9/user-guide/getting-started.html#docker)

HiveMQ Cloud:  
[https://www.hivemq.com/docs/hivemq/4.9/user-guide/getting-started.html#hivemq-cloud](https://www.hivemq.com/docs/hivemq/4.9/user-guide/getting-started.html#hivemq-cloud)

Thanks,  
Seth - HiveMQ Support

---

<div class="post-metadata">

**Author:** ![hejazi090](https://yyz1.discourse-cdn.com/flex035/user_avatar/community.hivemq.com/hejazi090/32/500_2.png) [@hejazi090](https://community.hivemq.com/u/hejazi090)\
**Post date:** [December 6, 2022, 6:51pm UTC](https://community.hivemq.com/t/change-the-localhost-ip-to-my-server-ip/1654/4 "2022-12-06T18:51:50Z")

</div>

Dear Seth,

Thanks alot for your kind support the issue was because I did the change on config file during the docker image built and the container is running.

I solved by download the docker image from your repository then change the config file and then build the image.

Best Regards,  
Amer Hijazi,
